Current Service Status

BoB is experiencing slow performance Monday 14th October 2019 10:28:00


RESOLVED 10:45am This issue has been fixed.

Update 10:28am Sorry, BoB is currently running a little slow. We are investigating these issues and will provided more information as soon as possible. Apologies for any inconvenience.